With the announcement of the new Arista cert, the ACE-A, or Arista Certified Engineering Associate exam I am finding myself studying for certs all over again! The exam is very new and was just announced this month! Unfortunately there is no real “Arista Press” book on this exam, so to help with that I will start posting a series of Arista category blog posts to help people learn some of the concepts and CLI!

Now if you are looking for a blueprint of what the test consists of…

Module 1: Arista Hardware Overview

  1. Data Center Cloud Architecture
  2. Arista Fixed Form Factor Switch Overview
  3. Arista Modular Chassis Switch Overview
  4. MXP Ports and Breakout Technology
  5. MXP Port Configuration

Module 2: Extensible Operating System (EOS) Overview

  1. Design Principles of EOS
  2. Sysdb Overview
  3. Benefits of EOS
  4. Interacting with EOS
  5. Introduction to EAPI
  6. EOS Naming Convention
  7. EOS Lifecycle

Module 3: Switch Configuration Basics

  1. Switch Access & CLI Introduction
  2. Basic Configurations
  3. Logging
  4. Interface Configuration
  5. VLAN and Trunk Configuration
  6. Portchannel & LACP Configuration
  7. LACP Fallback
  8. Basic Spanning Tree Protocol Configuration
  9. Linux Shell Acces
  10. Management VRF

Module 4: Switch Maintenance

  1. Aboot Overview
  2. EOS Upgrade Procedures
  3. Modular Redundant Supervisor Upgrade Procedures
  4. Password Recovery Procedure
  5. Recovery Procedures

Module 5: Zero Touch Provisioning (ZTP)

  1. ZTP Modes
  2. Operation
  3. Requirements
  4. Config Files vs. Scripts
  5. ZTP Examples

Module 6: Multi-Switch CLI

  1. Feature Overview
  2. Use Cases
  3. Requirements
  4. AAA Integration
  5. Configuration and Operation

Module 7: Multi-Chassis LAG (MLAG)

  1. Definition and Purpose
  2. Operation- Peerlink, Election, L2 Protocols
  3. Stateful Switchover (SSO)
  4. In-Service Software Upgrade (ISSU)
  5. Configuration and Verification
  6. MLAG and Virtual ARP (VARP)

Module 8: Virtual Extensible LAN (VXLAN) Overview

  1. Definition and Purpose
  2. Terminology
  3. Encapsulation
  4. Operation
  5. Head-End Replication Configuration
  6. Verifying VXLAN Operation

Module 9: Monitoring Topics

  1. Simple Network Management Protocol (SNMP)
  2. SFLOW
  3. TCPDUMP Overview
  4. TRACE Overview
  5. Port Mirroring Configuration
  6. Advanced Event Management (AEM) Overview
  7. CLI Scheduler
  8. Event Monitor
  9. Event Manager
  10. Latency Analyzer (LANZ
  11. Digital Optical Monitoring (DOM)

Module 10: VM Tracer Overview

  1. Data Center Virtualization Challenges
  2. Supported Functions
  3. Operation
  4. Viewing VM Tracer Information
  5. VM Adaptive Segmentation
  6. Configuration

Module 11: DANZ Overview

  1. Agile Ports
  2. Advanced Mirroring
  3. Mirror to EOS
  4. Using ACLs to Filter Mirror Sessions
  5. Packet Truncation
  6. Time Stampin
  7. Tap Aggregation Mode

Module 12: EAPI Overview

  1. Understanding EAPI
  2. EAPI vs. Screen Scraping
  3. Configuration and Verification
  4. Using Python with EAPI

 

The exam is based off of the official Arista ACE class, which can be taken in person or via webiar. Details for this exam can be found here. Information regarding the exam via Pearson Vue can be found here.

 

OK so lets get into the meat of this blog, how do we configure MLAG? Before that, if you need to setup vEOS, check this blog out from Gary Donahue. Even better, if you want to plug vEOS into GNS3 to play with other vendor switches, or the Unified Networking Lab (UNL), or just run vEOS boxes without GNS3 or UNL, your free to choose your preference!

For this example, I’ll use 3 vEOS boxes. As of this writing the latest vEOS version is 4.15.2F which is the code I am using here. vEOS-4 will connect to our MLAG pair using

Now if you’ve ever configured regular port channels on Cisco devices, or a vPC on a Nexus, you’ll find yourself at home here. CLI it is very similar.

First off, if your doing this in a vm, in order to simulate p2p links between the switches, we’ll make a custom vmnet (VM Workstation) orĀ inet (VirtualBox) for host only networking and have both ends of the wire connected to this network. So for example, eth1 of both vEOS-2 and vEOS-3 will be connected to vmnet2, which in turn gets connected to a host-only network.

networks

 

Now, for the configuration. Above I will be creating a port channel 10 using interfaces eth1 and 2. Note this config has to go on both switches.

config t
int eth1-2
channel-group 10 mode act
int po10
switchport mode trunk

Next, for the MLAG config. This also goes on both switches.

vlan 4094
trunk group mlagpeer
int po10
switchport trunk group mlagpeer
exit
no spanning-tree vlan4094

Now for the individual configuration. Lets start with vEOS-2…

interface Vlan4094
ip address 10.0.0.1/30
mlag configuration
domain-id mlag1
local-interface Vlan4094
peer-address 10.0.0.2
peer-link Port-Channel10

And for vEOS-3

interface Vlan4094
ip address 10.0.0.2/30
mlag configuration
domain-id mlag1
local-interface Vlan4094
peer-address 10.0.0.1
peer-link Port-Channel10

Done! Now all we need to do is verify if the MLAG is up. A simple #show mlag will do this for us. Note the other options we have by using the ? mark

vEOS-3#show mlag
MLAG Configuration:
domain-id : mlag1
local-interface : Vlan4094
peer-address : 10.0.0.1
peer-link : Port-Channel10
peer-config : consistent

MLAG Status:
state : Active
negotiation status : Connected
peer-link status : Up
local-int status : Up
system-id : 02:0c:29:24:2e:40

MLAG Ports:
Disabled : 0
Configured : 0
Inactive : 0
Active-partial : 0
Active-full : 1

vEOS-3#show mlag ?
config-sanity check peer MLAG configuration sanity
detail With details for debugging
interfaces MLAG interfaces
issu MLAG ISSU information
tunnel MLAG tunnel information
> Redirect output to URL
>> Append redirected output to URL
| Output modifiers
<cr>

Finally, we’ll need to make a MLAG enabled Portchannel. This is fairly easy to do on both switches…

interface Ethernet3
channel-group 3 mode active
interface Port-Channel3
mlag 3

Now on vEOS-4, all we need to do is off eth1 and 2 interface, simply create a regular port channel pointing up to the MLAG.

interface Port-Channel3
!
interface Ethernet1
channel-group 3 mode active
!
interface Ethernet2
channel-group 3 mode active

 

 

 

 

William Zambrano

William Zambrano

NYC networkers is run by William Zambrano, a passionate network engineer who has been in the IT industry for eight years who posts up blog articles, YouTube videos, and holds meetup.com events in the NYC area. He lives in Queens, New York and has consulted in various different companies in the NY area. Previously William worked as a Cisco Certified Systems Instructor (CCSI) but now currently works for Arista Networks serving as a Systems Engineer. William can be reached by email at willzambrano@gmail.com

More Posts - Website

Follow Me:
Twitter